[PCSX2] The MRP (MGO, Ready-to-Play) package!

Find tutorials, ask for help, and find others with similar issues.
Bitman[FR]
Posts: 15
Joined: Wed Nov 09, 2016 10:41 pm

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Thu Nov 10, 2016 4:10 pm

Hello,

Thanks you for the answer, unfortunetely, if if only it was that simple, :(

It also failed the same way running as administrator, and the DEV9 plugin still not working and cannot recognize my network adapter.
I've saved the pcsx2 log while running the game, here it is.

Am I still doing something wrong or did I missed something ?
Thanks for your time.

UPDATE: I've managed myself to readjust the settings and there is some progress.
I am like one step away from this completely working.
I encounter however the udp port check error, do you have any clue about it ?

Thanks you for your time.
Attachments
Log MGO failed trial.zip
(3.69 KiB) Downloaded 43 times
User avatar
GHzGangster
Site Admin
Site Admin
Posts: 571
Joined: Tue May 17, 2016 5:21 am

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Sun Nov 13, 2016 5:21 am

Do you have WinPCAP installed?
Bitman[FR]
Posts: 15
Joined: Wed Nov 09, 2016 10:41 pm

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Sun Nov 13, 2016 1:11 pm

GHzGangster wrote:Do you have WinPCAP installed?

Hello GHzGangster,

Yes I've checked a dozen times if it was installed, everytime noticed me that it was installed already and if I wanted to force the installation anyways.

I've also tried to open the ports 5730 and 53 on my router for my pc but still does not work.
Some people tip me to put automatic ip but I can't do it since it does not have the option to.
I'm getting desesperate lol
User avatar
GHzGangster
Site Admin
Site Admin
Posts: 571
Joined: Tue May 17, 2016 5:21 am

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Mon Nov 14, 2016 6:46 am

Oh sorry, I didn't read the whole post...
If you're actually able to start some sort of connection in-game, then make sure that you are setting a static IP in the Network Access Disc. You don't want it to be the same as your PC, or anything else on your network.
Bitman[FR]
Posts: 15
Joined: Wed Nov 09, 2016 10:41 pm

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Wed Nov 16, 2016 12:44 am

Hey,

I've changed the ip but nothing change still getting that udp error.
There's one thing that disturbs me however, when I watch some of the mgo tutorial for pc, when they have the ethernet option enabled for the dev9 plugin they might see their network card but on my side I cannot, this is only switch or bridge microsoft, my card isn't mentionned is there anything related to it ?

Thanks for your help
User avatar
GHzGangster
Site Admin
Site Admin
Posts: 571
Joined: Tue May 17, 2016 5:21 am

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Wed Nov 16, 2016 3:46 pm

I'm not sure... the error log you posted made it seem like it wasn't able to list all the network devices, but I don't have a clue why that would happen.
Maybe you can try installing https://github.com/nmap/npcap/releases and see if that helps.
Bitman[FR]
Posts: 15
Joined: Wed Nov 09, 2016 10:41 pm

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Thu Nov 17, 2016 1:26 am

Hello,

That was still a good idea, since the dev9 plugin now sees the network card, unfortunetely I still have that udp error check, I think we're gonna be out of ideas sadly. I think I will ask someone who play on emulator to send to me his own prepared by himself mgo package just to differenciate between mine and his. I do certainly miss a step or I'm definitively out of luck.

Thanks you Gangster for your time however, really appreciate it !
Bitman[FR]
Posts: 15
Joined: Wed Nov 09, 2016 10:41 pm

Re: [PCSX2] The MRP (MGO, Ready-to-Play) package!

Sun Dec 04, 2016 12:24 am

UPDATE: I've finally managed to make MGO 1 working on PCSX2.
I wanted to write here because it mays also help other people that still get that udp error even though they have tried everything else.

I've downloaded this experimental plugin from the pcsx2 forum: http://forums.pcsx2.net/Thread-Experime ... DD-Support

1) Once you extract the document with for example Winrar, grab the .dll and put it in the plugins file of your PCSX2 document.
2) Launch PCSX2 as an administrator
3) Go to plugins/bios selector/plugins
4) Choose CLR DEV9 in the DEV9 plugin
5) After that, you'll have to configure the DEV9 plugin, go to config/DEV9/config settings
6) No need to put enable HDD on, just enable ethernet, and go the enable ethernet options settings
7) Take Winpcap bridged as the connection method
8) I'm using wifi so it is gonna be Wifi Microsoft as the Adapter, I haven't tried via ethernet yet.
9) Enable the intercept DHCP so you can configure the net settings
10) Just put a static IP in the PS2 IP Adress, and also configure the subnet masc and the gateway IP
11) You'll also have to put the DNS from the Savemgo server, 192.3.217.61 for the DNS1 IP, 192.3.217.162 for the DNS2 IP, then apply !
12) With all of those settings, you will still have to configure the network with an network access disc, I haven't tested without however yet, might worth a shot.
13) Once you have done everything, you can launch the Persistence disc with of course the cheats enabled and the hostfile system in the System settings of your PCSX2 document.
14) One last thing: For my personal case, I've had to put the auto router off in order to avoid the udp error check in plus, so maybe do you. (in the mgo network settings)

I'm sorry for the long post, but all of this was required for me in order to launch MGO properly.

Hope that this can help some of you people, and sorry if there's any english mistakes.

Sincerely,

Bitman

Return to “MGO1 Support”

Who is online

Users browsing this forum: No registered users and 1 guest

Discord

Forum Theme