4.80 CFW Now Required

Site and server news.
User avatar
GHzGangster
Site Admin
Site Admin
Posts: 837
Joined: Mon Jun 18, 2012 8:02 pm

4.80 CFW Now Required

Wed Oct 26, 2016 1:43 am

Due to unknown circumstances, 4.80 CFW is now required.
I believe this is an issue with some change on our web host's side, but I am not sure.

We suggest you update to Rebug 4.80, here. (As a reminder, you download a TXT file, the real download link is inside of it)
If your Blu-Ray Drive is broken, you can download a No-BD version here.

You may also need to update the launcher, here: http://savemgo.com/forums/viewtopic.php?f=11&t=3

Image

Return to “News”

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest

Discord

Forum Theme