System update required

Ask for help, and find others with the same issue.
Temp
Posts: 5
Joined: Sun Jun 25, 2017 1:48 pm

System update required

Fri Jul 28, 2017 2:33 am

Says system update is required when i hop onto play OFW, currently says im on ver 1.36. Any way to fix? Also when it asks me to sign in what email/password should i be using, the one used to make my forumn account here?

Return to “MGO2 Support”

Who is online

Users browsing this forum: No registered users and 2 guests

Latest Posts

Discord

Forum Theme